ADOdb

Database Abstraction Layer for PHP

User Tools

Site Tools


v5:database:mysql_legacy

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

v5:database:mysql_legacy [2020/01/13 13:25]
dregad created
v5:database:mysql_legacy [2020/01/13 13:30] (current)
dregad Add section "Migrating to the mysqli driver" (moved from mysql page)
Line 3: Line 3:
 This page references deprecated legacy drivers for MySQL. Please refer to [[v5:​database:​mysql]] for the current, supported driver (mysqli). This page references deprecated legacy drivers for MySQL. Please refer to [[v5:​database:​mysql]] for the current, supported driver (mysqli).
  
 +===== Migrating to the mysqli driver =====
 +
 +If you are still using the legacy //mysql//, //mysqlt// or //mysqlpo// drivers, you should be planning on migrating to the **[[v5:​database:​mysql|mysqli driver]]**. Support for both drivers is built into PHP up to version PHP 5.4. From an ADOdb standpoint, it is simply a case of switching from 
 +
 +  $db = newAdoConnection('​mysql'​)
 +to
 +  $db = newAdoConnection('​mysqli'​)
 +
 +--------------------------------------
  
 ===== mysql driver ===== ===== mysql driver =====
v5/database/mysql_legacy.txt ยท Last modified: 2020/01/13 13:30 by dregad